TechnikTeam Forum  

Zurück   TechnikTeam Forum > Computer > Linux

Linux Hier geht es um das Betriebssystem LINUX !

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 06.06.2005, 21:28   #1
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
Frage Problem: parallele Schnittstelle

Hallo Linux-Freaks,

ich habe seit kurzem ein Problem mit meiner parallelen Schnittstelle unter Linux DEBIAN (SARGE).
Ich spreche ein graphisches Display über die parallele Schnittstelle an. Das entsprechende Plugin läuft (meines Wissens) mit root-Rechten.

Hier mal die Meldungen aus dem Syslog:

graphlcd plugin: ERROR: ioperm(0x378) failed! Err:Operation not permitted (cParallelPort::Open)

Ich habe schon versucht, das Plugin über /dev/parport0 anzusprechen (dazu sind dann ja keine root-Rechte nötig), allerdings änderte das nicht besonders viel an der Fehlermeldung.
Hier sagt die Fehlermeldung beim Öffnen des Parallelports auch etwas von fehlenden Berechtigungen.

Diese Fehlermeldung muss ja nun nicht gleich zwangsläufig bedeuten, daß ich nicht die entsprechende Berechtigung habe (als root muesste ich sie ja wohl haben), sondern könnte ja auch daher rühren, daß der Parallelport bereits belegt ist.
Wie bekomme ich denn raus, ob das Modul für den Parallelport geladen wurde, und wie kann ich rauskriegen, ob bereits jemand oder etwas den Parallelport belegt hat?

Oder wiss etwa jemand auch gleich eine direkte Antwort??
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:25   #2
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Poste mal die ausagbe von lsmod
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:29   #3
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
Module Size Used by Not tainted
dvb-ttpci 282612 18
stv0299 8912 1
ttpci-eeprom 1280 0 [dvb-ttpci]
input 3104 0 [dvb-ttpci]
dvb-core 55324 0 [dvb-ttpci stv0299]
saa7146_vv 33852 0 [dvb-ttpci]
saa7146 10272 0 [dvb-ttpci saa7146_vv]
video-buf 10880 0 [saa7146_vv]
videodev 5760 1 [saa7146_vv]
v4l2-common 2880 0 [saa7146_vv]
v4l1-compat 11496 0 [saa7146_vv]
ehci-hcd 16844 0 (unused)
usb-uhci 21584 0 (unused)
usbcore 56908 1 [ehci-hcd usb-uhci]
via-rhine 12208 1
mii 2144 0 [via-rhine]
dm-mod 42136 0 (unused)
lirc_serial 7296 1
unix 13968 7 (autoclean)
ext3 62692 2 (autoclean)
jbd 45168 2 (autoclean) [ext3]


Sorry für die Formatierung ...
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin

Geändert von Herthaner (06.06.2005 um 22:35 Uhr).
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:33   #4
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Nein, da müsste eigentlich parport erscheinen.
Rufe mal modconf auf. Dort kannst du deine Module konfigurieren.
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:36   #5
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
modconf jibbed bei Debian wohl nicht
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:37   #6
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
vielleicht base-config?
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:39   #7
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
modconf gibt es NUR bei Debian...
apt-get install modconf
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:46   #8
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
Hab ich genmacht.
Ich habe dann Parport ausgewählt und gesagt, er solls instrallieren.
Aber jetzt fragt er mich nach:

"Bitte geben Sie die Kommandozeilen-Argumente für das Modul parport ein."
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:50   #9
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Da gibst du nix ein...
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:52   #10
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
Okey, hab ich gemacht.
Aus alter Gewohnheit mach ich jetzt mal einen Neustart ... und schau mal, obs geholfen hat, bzw. was syslog jetzt sagt.
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 22:56   #11
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Ist eigentlich unnötig, aber nun ist wohl eh zu spät.

Aber es kann sein, das du noch daß Modul ppdev nachladen mußt. Aber das heist irendwie anders. Ich schaue mal, was ich finde...
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 23:09   #12
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
So, hier jetzt das Info von lsmod nach der Installation von parport

Module Size Used by Not tainted
dvb-ttpci 282612 18
stv0299 8912 1
ttpci-eeprom 1280 0 [dvb-ttpci]
input 3104 0 [dvb-ttpci]
dvb-core 55324 0 [dvb-ttpci stv0299]
saa7146_vv 33852 0 [dvb-ttpci]
saa7146 10272 0 [dvb-ttpci saa7146_vv]
video-buf 10880 0 [saa7146_vv]
videodev 5760 1 [saa7146_vv]
v4l2-common 2880 0 [saa7146_vv]
v4l1-compat 11496 0 [saa7146_vv]
ehci-hcd 16844 0 (unused)
usb-uhci 21584 0 (unused)
usbcore 56908 1 [ehci-hcd usb-uhci]
via-rhine 12208 1
mii 2144 0 [via-rhine]
dm-mod 42136 0 (unused)
parport 22280 0 (unused)
lirc_serial 7296 1
unix 13968 7 (autoclean)
ext3 62692 2 (autoclean)
jbd 45168 2 (autoclean) [ext3]

Problem besteht immernoch, Fehlermeldung im syslog ist identisch.
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 23:14   #13
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Support for user-space parallel port device drivers

muß noch im Kernel aktiviert werden. Das heißt, du musst den Kernel neu kompilieren, es sei denn, du findest das als Modul.

Versuche mal modprobe ppdev...
Trigger ist offline   Mit Zitat antworten
Alt 06.06.2005, 23:20   #14
Herthaner

Moderator
 
Benutzerbild von Herthaner
 
Registriert seit: 6.01.2000
Ort: Berlin
Beiträge: 1.432
Herthaner befindet sich auf einem aufstrebenden Ast
So eingeben, wie Du es geschrieben hast?

Dann sagt er:

ppdev: user-space parallel port driver
__________________
so genau kann man(n) das nie sagen - man(n) steckt ja nicht drin!

IT-EASY Berlin
Herthaner ist offline   Mit Zitat antworten
Alt 06.06.2005, 23:21   #15
Trigger
Gold Status
 
Benutzerbild von Trigger
 
Registriert seit: 9.06.2002
Ort: Hamburg
Beiträge: 2.012
Trigger befindet sich auf einem aufstrebenden Ast
Ja
modprobe ppdev
Trigger ist offline   Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
NT4.0 IE Problem respektator Windows 95/98/ME/NT 2 13.03.2003 15:18
Problem mit CPU? Schmidti2k Hardware 3 04.03.2003 16:21
Problem mit Battlefield und IL2 Sturmovik Ulic Software 1 25.10.2002 09:53
Problem mit Administratorrechten Ulic Windows 2000/XP/Vista/Win7/Win8/Win10 7 10.10.2002 19:45
W2k und ISDN Problem u96 Windows 2000/XP/Vista/Win7/Win8/Win10 10 08.04.2000 00:57


Alle Zeitangaben in WEZ +2. Es ist jetzt 07:13 Uhr.


Powered by vBulletin® Version 3.7.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
Design by TechnikTeam.de (Alle Rechte vorbehalten)
Besucher: 13827160 Online: 212